Mastercard Secure Card on File is experiencing problems

Incident Report for Frisbii

Resolved

Mastercard has resolved the issue. We have been in ongoing contact with them throughout, but no root cause has been provided. We will continue to pursue an explanation.
Posted Sep 03, 2026 - 19:48 CEST

Investigating

We are currently seeing timeout and processing errors in our communication with Mastercard. This affects new sign-ups and card-on-file transactions using Mastercard cards.

Merchants may see failed or delayed authorizations, and cardholders may be unable to complete card registration. Other card schemes are unaffected.
Posted Sep 03, 2026 - 17:03 CEST
This incident affected: Scheme Tokenization (Mastercard Secure Card on File).