Bank Nordea issue with Visa debit cards

Incident Report for Frisbii

Resolved

This incident has been resolved.
Posted Feb 27, 2026 - 11:07 CET

Investigating

The Danish bank Nordea is currently experiencing an issue with Visa debit cards with prefix 402620.
Posted Feb 27, 2026 - 10:34 CET