Card processing through Nets for Mastercard is currently experiencing problems

Incident Report for Frisbii

Resolved

The issue was resolved by the provider (Nets). Mastercard transactions are now processing as expected.
Posted Jul 28, 2025 - 10:41 CEST

Identified

Card processing through Nets for Mastercard is currently experiencing issues. We are monitoring the situation and will provide updates as soon as we receive them from acquirers/Nets.
Posted Jul 22, 2025 - 14:19 CEST