Acquirer Nets is experiencing problems

Incident Report for Frisbii

Resolved

This incident has been resolved.
Posted Mar 30, 2026 - 14:26 CEST

Investigating

Nets acquiring and processing is currently experiencing problems. We are investigating the issue.
Posted Mar 30, 2026 - 14:17 CEST
This incident affected: 3rd Party - Card Acquiring (Nets, Swedbank (Nets), Elavon (Nets), Bambora (Nets), Valitor (Nets)).