Swish is experiencing problems

Incident Report for Frisbii

Resolved

The incident by Payment provider Swish is resolved
Posted May 22, 2025 - 17:26 CEST

Monitoring

Payment provider Swish is experiencing problems. It is currently not possible to initiate Swish payments.
Posted May 22, 2025 - 14:40 CEST
This incident affected: 3rd Party - Payment Methods (Swish).