PayPal is experiencing problems

Incident Report for Frisbii

Resolved

This incident has been resolved.
Posted Aug 01, 2025 - 16:37 CEST

Monitoring

Payment provider PayPal is experiencing problems.
Posted Aug 01, 2025 - 15:01 CEST
This incident affected: 3rd Party - Payment Methods (PayPal).