Swish Planned maintenance

Incident Report for Frisbii

Resolved

Our provider has completed their scheduled maintenance. All systems are functioning as expected.
Posted Dec 09, 2025 - 08:44 CET

Monitoring

Swish has announced the following planned maintenance affecting payments
Posted Dec 09, 2025 - 05:57 CET
This incident affected: 3rd Party - Payment Methods (Swish).