Issues with Apple Pay payments

Incident Report for Frisbii

Resolved

This incident has been resolved. From 12:28 to 12:47 we saw intermittent problems with Apple Pay. We are currently investigating the root cause of this incident.
Posted Jun 11, 2025 - 13:19 CEST

Investigating

We are currently investigating an issue with Apple Pay payments
Posted Jun 11, 2025 - 12:44 CEST
This incident affected: 3rd Party - Payment Methods (Apple Pay).