Acquirer Elavon (native) communication errors

Incident Report for Frisbii

Resolved

This incident has been resolved.
Posted Feb 19, 2026 - 09:24 CET

Monitoring

A fix has been deployed, and we are now seeing normal transaction processing. We will continue to monitor the situation and work with Elavon to determine the root cause of the incident.
Posted Feb 19, 2026 - 09:13 CET

Identified

The root cause of the incident has been identified. We are working on a fix with Elavon.
Posted Feb 19, 2026 - 08:55 CET

Investigating

We are currently experiencing a connectivity issue with Elavon (native). We are investigating the issue with Elavon.
Posted Feb 19, 2026 - 08:28 CET
This incident affected: 3rd Party - Card Acquiring (Elavon (native)).