Acquirer Nets is experiencing problems

Incident Report for Frisbii

Resolved

Nets have made a rollback of change deployed earlier today. That has resolved the issue.
Posted Sep 15, 2025 - 17:33 CEST

Update

The problem at Nets affects payments with international cards. Nets have setup a task force to resolve the issue.
Posted Sep 15, 2025 - 17:19 CEST

Investigating

Transactions using Nets are currently experiencing problems. We are investigating the issue and have reached out to Nets.
Posted Sep 15, 2025 - 15:42 CEST
This incident affected: 3rd Party - Card Acquiring (Nets, Swedbank (Nets), Elavon (Nets), Bambora (Nets), Valitor (Nets)).