An analytics integration partner is having issues causing our revenue insights feature to be down at the moment

Incident Report for Frisbii

Resolved

This incident has been resolved.
Posted Jan 06, 2026 - 21:37 CET

Update

We are continuing to monitor for any further issues.
Posted Jan 06, 2026 - 16:44 CET

Monitoring

We are monitoring the incident closely.
Posted Jan 06, 2026 - 16:42 CET
This incident affected: Administration.