Swish is experiencing problems

Incident Report for Frisbii

Resolved

This incident has been resolved.
Posted Dec 09, 2025 - 11:38 CET

Identified

Payment provider Swish is experiencing problems. It is currently not possible to initiate Swish payments. For more information: https://status.swish.nu/
Posted Dec 09, 2025 - 11:33 CET
This incident affected: 3rd Party - Payment Methods (Swish).