Paypal is experiencing problems

Incident Report for Frisbii

Resolved

The incident is resolved.
Posted Nov 21, 2024 - 14:26 CET

Monitoring

According to the PayPal Status Page, the incident is resolved. We are monitoring this a bit further, in order to make sure our checkout is working flawlessly again.
Posted Nov 21, 2024 - 14:20 CET

Investigating

Paypal is currently experiencing problems, causing a partial outage for payments using this payment method.
Posted Nov 21, 2024 - 13:51 CET
This incident affected: Checkout.