Acquirer Nets is experiencing problems

Incident Report for Frisbii

Resolved

This incident has been resolved.
Posted Sep 04, 2026 - 15:19 CEST

Investigating

Nets is currently experiencing issues with elevated decline rates. Awaiting further information from Nets. Nets processing to other acquirers not affected.
Posted Sep 04, 2026 - 14:58 CEST
This incident affected: 3rd Party - Card Acquiring (Nets).