Nets is experiencing problems

Incident Report for Frisbii

Resolved

This incident has been resolved.
Posted Mar 11, 2026 - 21:58 CET

Investigating

Nets authentications are currently experiencing problems. We are investigating the issue.
Posted Mar 11, 2026 - 21:26 CET
This incident affected: Strong Customer Authentication (Secured by Nets).