3DS is experiencing problems

Incident Report for Frisbii

Resolved

This incident has been resolved.
Posted Jul 15, 2026 - 11:51 CEST

Update

We are continuing to monitor for any further issues.
Posted Jul 15, 2026 - 11:11 CEST

Update

We are continuing to monitor for any further issues.
Posted Jul 15, 2026 - 11:09 CEST

Monitoring

Integration is working now. And we are monitoring for any further issues.
Posted Jul 15, 2026 - 11:09 CEST

Update

We are continuing to investigate this issue.
Posted Jul 15, 2026 - 10:43 CEST

Investigating

3DS authentications are currently experiencing problems. We are investigating the issue.
Posted Jul 15, 2026 - 10:03 CEST
This incident affected: Strong Customer Authentication (3D Secure).