Microsoft Edge Browser False Positive Affecting Checkout

Incident Report for Frisbii

Resolved

We have not been able to reproduce the issue during the day, and we have not received any additional reports. It appears that once a customer has been shown the warning, it will continue to reappear until the customer marks it as a false positive. Customers experiencing the issue should be advised to click “Report that this site URL is not a misspelling” and then “Proceed.”.

Rest assured that this issue will continue to have our full attention. We consider it a bug in Microsoft Edge and will continue working with Microsoft to ensure it does not happen again.
Posted Nov 17, 2025 - 16:44 CET

Update

We have been inspecting technical measures to mitigate this issue and have reached out to Microsoft to help resolve it. At this time, we are not able to reproduce the issue.

We will continue to monitor the issue and keep working with Microsoft to ensure it is resolved permanently.
Posted Nov 17, 2025 - 08:26 CET

Identified

Some customers using Microsoft Edge browser may currently see a false warning when accessing our Checkout page due to Edge's "Website typo protection" feature incorrectly flagging our Checkout page. This is a new Edge feature and is beyond our control.

This is a false positive only — Checkout is fully secure, and no systems or data are at risk. Customers can proceed safely and mark the domain as not misspelled, or use another browser.
Posted Nov 14, 2025 - 16:03 CET
This incident affected: Checkout.